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Introduction

In This Chapter
This chapter contains the following sections:

• A Word of Thanks
• Overview

A Word of Thanks
Congratulations on choosing the DashBoard Control System™. DashBoard is part of a full line of 
Digital Products within the openGear Terminal Equipment family of products, backed by Ross 
Video's experience in engineering and design expertise since 1974.

You will be pleased at how DashBoard fits into your overall working environment. Equally 
pleasing is the product quality, reliability and functionality. Thank you for joining the group of 
worldwide satisfied Ross Video customers!

Should you have a question pertaining to the installation or operation of DashBoard, please 
contact us at the numbers listed on the back cover of this manual. Our technical support staff is 
always available for consultation, training, or service.

Overview
This manual provides an overview of installing, setting up, and using the DashBoard client. For 
information on using the DashBoard Server and User Rights Management features, refer to the 
DashBoard Server and User Rights Management User’s Guide.

The DFR-8300 series frames offers remote control and monitoring with the combination of the 
openGear Network Interface card and the DashBoard Control System™. This allows users to 
remotely monitor and control parameters on openGear devices that support remote control.

The DashBoard Control System is built on Ethernet and TCP/IP technology, which allows remote 
access across LAN architectures.

Monitoring
A network of openGear frames and cards can be monitored, allowing users to quickly isolate and 
correct potential problems from a central monitoring station.
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Control
DashBoard offers real-time control of openGear card parameters. Parameter types vary 
depending on card functionality.

DataSafe™
DataSafe enables you to backup and restore card parameters to and from a single file, copy 
parameters from one card to a another card or even a group of cards via DashBoard. This feature 
allows you to hot-swap cards while retaining configurations, and DashBoard is not required to 
have the parameters on the new card updated. You can update a subset of devices instead of the 
entire connected view or to replace a card and have the previous card settings automatically 
loaded onto the new card. This feature is available for frames using the MFC-8310-N and 
MFC-8320-N series cards only. 

Software Upgrades
Most openGear cards can be upgraded, both software and firmware, in the field using DashBoard. 
The upgrade utility verifies firmware and software upgrades against card hardware in the frame 
and prevents accidental loading of incorrect files to the wrong hardware. DashBoard is designed 
to allow for future feature plug-ins and upgrades to allow users the ability to customize control 
and monitoring needs.

Features
The following features make DashBoard a unique system for your openGear requirements:

• DashBoard software and manual are available for download from the Ross Video website
• Store and upload configurations to multiple cards (using DataSafe)
• Customize views with the installation of the Advanced Tree View licensed feature
• Java™ based for installation in Microsoft Windows®, Mac® OS, and Linux® Fedora®
• Multiple openGear frames on a single control network
• Multiple DashBoard applications on a single control network
• Automatic discovery of frames and devices
• Software and firmware upgrades via ethernet
• Extensible plug-in architecture

Documentation Terms and Conventions
The following terms and conventions are used throughout this manual:

• “Frame” refers to any openGear frame within your video system. 
• All references to the DFR-8300 series frame also includes all version of the 10-slot and 

20-slot frames and any available options.
• “User” refers to the person who uses DashBoard.
• “Card” refers to openGear terminal devices within openGear frames, including all 

components and switches.
• “Network Controller Card” refers to the MFC-8310-N series and MFC-8320-N series 

cards unless otherwise noted.
• “System” refers to the mix of interconnected production and terminal equipment in your 

environment.
• “Device” refers to an openGear frame or card listed in DashBoard. 
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• “Tree View” refers to the Basic Tree View and Advanced Tree View unless otherwise 
noted. 

• “DashBoard window” refers to the main DashBoard client interface.
• Navigation procedures in this manual assume that you are running Microsoft Windows®. 

If you are running Mac® OS or Linux® Fedora®, the menus names and options may 
differ.

• Some navigation procedures in this manual state the menu items, located on the main 
DashBoard toolbar, you are to select followed by the “>” symbol.

• “Operating Tips” and “Note” boxes are used throughout this manual to provide 
additional information.
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Installing DashBoard

In This Chapter
This chapter provides instructions for installing the DashBoard Control System client software. 
For information on installing the DashBoard URM and Server, refer to the DashBoard Server 
and User Rights Management User Manual.

The following topics are discussed:

• Before You Begin
• Installing the DashBoard Control System Client
• Activating DashBoard Licensed Features
• Viewing Installation Details
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Before You Begin
Before installing any software for your DashBoard Control System client, ensure that you exit all 
other programs currently running. 

System Requirements
Refer to the following sections for information on the system requirements for DashBoard.

Microsoft® Windows® XP/XP64/Vista/Vista64 Systems
The following are the minimum requirements when installing DashBoard on a Microsoft® 
Windows® system:

• Intel® Pentium 4, 1.6GHz (Intel® Core™ 2 Duo recommended)
• 1GB or more of RAM (2GB is recommended)
• 200MB available in HD space
• Microsoft® Internet Explorer® version 5 (minimum)

Apple Mac® OS X 10.5 (Leopard®) / 10.6 (Snow Leopard™) / 10.7 
(Lion™) Systems
The following are the minimum requirements when installing DashBoard on a Mac® OS system:

• Intel® Core Duo processor
• 1GB or more of RAM (2GB is recommended)
• 200MB available HD space
• Java® 6 installed
• Mac® Safari®

Linux® Fedora® 9/10/11 Systems
The following are the minimum requirements when installing DashBoard on a Linux® system:

• Intel® Pentium 4, 1.6GHz (Intel® Core™ 2 Duo recommended)
• 1GB or more of RAM (2GB is recommended)
• 200MB available in HD space
• Version 2.2.1 GTK+ widget toolkit and associated libraries (GLib, Pango) are required
• Mozilla® 1.4GTK2 or higher

Note — Contact your I.T. Department if you experience communication issues with 
DashBoard and are running anti-virus software. You may need to verify that there is 
an exception in your firewall to allow DashBoard to receive UPD data via Port 427.
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Installing the DashBoard Control System Client
This section includes instructions on installing the DashBoard client to your computer. The 
DashBoard software and user manual are available from the openGear website 
(www.opengear.tv). 

Creating a Backup of the Settings and Licensed Features
Regular backups of your DashBoard settings is recommended, or if you want to create a backup 
of your DashBoard settings and license files, before installing a new version of DashBoard.

• Microsoft® Windows® — DashBoard automatically uninstalls a previously installed 
version, but not your settings.
› To create a back up your settings Microsoft® XP® and earlier, navigate to the 

metadata folder located at c:\Program Files\DashBoard\ workspace and copy the 
folder contents to a new location.

› If you are running Microsoft® Vista® or higher, the metadata folder is at: 
c:\openGear\DashBoard\workspace. Copy the folder to a new location.

• Apple® Mac® OS® — DashBoard saves application information to the following 
location on your computer: /Library/Application Support/openGear/DashBoard. To 
create a backup of your settings, copy the workspace folder to a different location on 
your system.

• Linux® Fedora® — DashBoard creates a workspace directory inside of the current 
DashBoard directory when the application is launched. To create a backup copy of your 
settings, copy the workspace directory to a different location on your system.

Installing on a Computer Running Microsoft® Windows®
Note that if you are running Microsoft® Vista® or higher, the DashBoard main folder is at: 
c:\openGear\DashBoard while previous Microsoft operating systems will install DashBoard to 
c:\Program Files\DashBoard.

Use the following procedure to install DashBoard on a computer running Microsoft Windows®: 

1. Access the DashBoard software using one of the following methods:

• Navigate to the openGear website (www.opengear.tv) and download the current 
software file.

• Load the DashBoard software CD into the DVD/CD ROM tray of your computer. 

2. If you are accessing the software from a CD, the Installation Wizard automatically 
runs. If the Wizard does not automatically run, you can also install the DashBoard 
software, navigate to your DVD/CD ROM drive in the Navigation Pane, so that the CD 
contents are displayed in the Main Window of Windows Explorer. 

3. Launch DB3.0.0-Win-setup.exe to begin installing the DashBoard program onto your 
computer.

4. Follow the prompts to complete the installation of DashBoard onto your computer.

This completes the procedure for installing DashBoard on a computer running Microsoft 
Windows®. 

Note — If you are upgrading your DashBoard Control System to software version 
2.0, or higher, the Install Wizard automatically uninstalls any previous software 
versions before proceeding.
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Installing on a Computer Running Apple® Mac® OS® X
Use the following procedure to install DashBoard on a computer running Apple® Mac® OS® X:

1. If you have a previous version of DashBoard installed, it is recommended that you 
remove the DashBoard directory from the Applications folder before proceeding.

2. Access the DashBoard software using one of the following methods:

• Navigate to the openGear website (www.opengear.tv) and click the link to the 
DashBoard installation program for Apple OS X. 

• Load the DashBoard software CD into the DVD/CD ROM tray of your computer 
and navigate to the DashBoard *.pkg file for Apple OS X.

3. Navigate to the *.pkg file you downloaded in step 2.

4. Double-click the *.pkg file to begin installing the DashBoard program onto your 
computer.

5. Follow the prompts to complete the installation of DashBoard onto your computer.

This completes the procedure for installing DashBoard on a computer running Mac® OS® X.

Installing on a Computer Running Linux® Fedora®
Use the following procedure to install DashBoard on a computer running Linux® Fedora®:

1. If you have a previous version of DashBoard installed and want to keep your settings, 
remove all folders, except the workspace directory, from the DashBoard directory. Note 
that the uninstall function of DashBoard may delete the directory that also contains your 
user data.

2. Access the DashBoard software using one of the following methods:

• Navigate to the openGear website (www.opengear.tv) and click the link to the 
DashBoard.tar.gz file for Linux.

• Load the DashBoard software CD into the DVD/CD ROM tray of your computer.

3. Extract the new DashBoard.tar.gz file to your system. Note that this file contains a 
top-level directory called DashBoard.

4. To run DashBoard, click the DashBoard icon in the top level of the DashBoard program 
folder. Note that if you run DashBoard from the command line, ensure that you switch to 
the main DashBoard directory before launching DashBoard.

This completes the procedure for installing DashBoard on a computer running Linux® Fedora®. 

Removing DashBoard
Ensure to create a backup for your settings and licensed features as outlined the section 
“Creating a Backup of the Settings and Licensed Features” on page 2-3 if you wish to retain 
your user data before removing DashBoard from your computer.

To remove DashBoard from a computer running Microsoft® Windows®:

• If you are using a computer running Microsoft® Windows®, use the Add/Remove 
Software program located in the Windows® Control Panel.

Note — DashBoard creates a workspace directory where the application is 
launched. This directory includes saved settings and licenses for optional features. To 
provide consistent retrieval of saved settings and program features, Ross Video 
recommends that you always launch Dashboard from within the same directory.
2–4 • Installing DashBoard DashBoard User Manual (Iss. 4.1)



• Do not delete the DashBoard directory, instead run the Add/Remove Software program. 
Deleting the directory without running the Add/Remove Software program results in a 
number of dead registry and start menu items on your system. You can delete the 
directory to remove your user data after you run the Add/Remove Software program.

To remove DashBoard from a computer running Apple® OS X®:

• Remove your user data from the application support library directory.
• Delete the Dashboard folder from your computer.

To remove DashBoard from a computer running Linux® Fedora®:

• Ensure to create a backup for your settings and licensed features if you wish to retain 
your user data.

• Delete the Dashboard folder from your computer.

Installing DashBoard Add-on Programs
This section briefly outlines how to install Add-on programs for DashBoard such as:

• openGear Extra Feature Pack — If you have an executable openGear Extra Feature 
pack, and are running Microsoft® Windows®, use the following procedure to install your 
feature pack. If you are not running Microsoft® Windows®, refer to the feature pack 
documentation for installation details.

• Unicode Font Support Pack — This program installs an international character set for 
DashBoard and provides access to fonts capable of displaying all Unicode characters. 
This program is not available for systems running Apple Mac® OS®. This option may be 
required if you are using an openGear device designed with fonts not supported by the 
base Java font system. Consult your device documentation for requirements and details. 

Use the following procedure to install a DashBoard Add-on program:

1. Navigate to the openGear website (www.opengear.tv) and download the required add-on 
program for your system.

2. If you are running Microsoft® Windows®:

• Launch the Setup Wizard for your Add-on program by selecting the corresponding 
*.exe file.

• Follow the prompts to complete the installation of the Add-on program.

3. If you are running Linux® Fedora®:

• Ensure you are in the main DashBoard directory before extracting the Add-on 
program.

• Copy the required *.zip to the main DashBoard directory.
• Extract the *.zip file.

This completes the procedure for installing a DashBoard Add-on program.
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Activating DashBoard Licensed Features
This section outlines how to install software keys to access DashBoard features such as the DB 
View. The required DashBoard software licenses must be purchased from your Ross Video sales 
representative before activating DashBoard licensed features. 

Logging into the DashBoard Client
If your facility has installed the DashBoard Server and URM feature, you may be prompted to log 
into the DashBoard client with a user ID each time the application is launched.

Use the following procedure to log into the DashBoard client:

1. Launch the DashBoard software by double-clicking the DashBoard icon on your 
desktop. The Login to DashBoard dialog displays.

2. In the Username field, type your User ID (in the form of an email address).

3. In the Password field, type your password. You can also change your password from 
this dialog by clicking Change Password and following the on-screen prompts.

4. From the Server menu, select the DashBoard Server you wish to log into.

5. Click OK.

Activating DashBoard Licensed Features
Use the following procedure to install a software license for a DashBoard feature:

1. Launch the DashBoard software.

2. Select the feature you wish to license as follows:

• From the main toolbar, select Window > Preferences.
• From the Preferences dialog box, select Licensed Features. A list of available 

licenses is displayed in the Licensed Features dialog box and is organized into 
subfolders. The Active subfolder includes those features currently installed on your 
computer. The Available subfolder lists the new features you can install on your 
computer.

3. From the Available subfolder, click the feature to license.

4. From the Licensed Features dialog box, click Install/Update License to open the 
Enter License Key dialog box. The Enter License Key dialog box can include your 
Request Code, and Hardware ID. You need this information when contacting Ross 
Video Technical Support. To print the information in the dialog box, click Print.

Operating Tip — DashBoard does not require that you install any of the optional 
licensed features.
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Figure 2.1  Enter License Key Dialog Box

5. Contact Ross Video Technical Support using the contact information in the section, 
“Company Address”. Ensure that you have the following information from the Enter 
License Key dialog box: Request Code, Hardware ID, and Feature ID. 

6. When you speak to our Technical Support representative, tell them your name, your 
facility name, and the Request Code as listed on the Enter License Key dialog box.

7. If you received a license key, enter the License Key in the License Key field. 

8. If you received a License file (*.keypack), click Install License Key Pack and follow 
the on-screen instructions in the Install License Key Pack dialog box.

9. Click Install to begin installing the key for the DashBoard software license. When the 
installation is complete, the License Installed dialog box opens.

10. Click OK.

This completes the procedure for installing a software license for a DashBoard feature. For 
information on updating installed licensed features, refer to the section “Updating DashBoard 
Features” on page 7-4.

Creating a Backup of your Licensed Features
Use the following procedure to create a backup file of your licensed features:

1. From the main DashBoard toolbar, select Window > Preferences.

2. From the Preferences dialog box, select Licensed Features.

3. Click Create Backup to display the Save dialog box.

4. Navigate to the location you wish to save your backup file to.

5. Enter a name for your backup file in the File Name: field.

6. Click Save.

This completes the procedure for creating a backup file of your licensed features.

Restoring your Licensed Features
Use the following procedure to restore your licensed features from a backup file:

1. From the main DashBoard toolbar, select Window > Preferences.

2. From the Preferences dialog box, select Licensed Features.

3. Click Restore From Backup to display the Install License Key Pack dialog box.
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4. Click Browse to navigate to the backup file you wish to use. The window below the 
Key Pack: field lists the licensed features included in the selected backup file.

5. Click Install.

This completes the procedure for restoring your licensed features from a backup file.
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Viewing Installation Details
You can view your installation history, activities in DashBoard, and error logs using the 
DashBoard Installation Details dialog box available from the About DashBoard dialog box. 

DashBoard Installation Details Overview
This section briefly explains the components of the DashBoard Installation Details dialog box 
should you need to view it for troubleshooting purposes or as directed by Ross Video Technical 
Support.

DashBoard Installation Details Dialog Box — Installed Software Tab

The DashBoard Installation Details dialog box includes the following tabs:

• Installed Software tab — This tab displays the currently installed DashBoard 
features, plug-ins, and application details. Details such as software version and ID 
are also provided. 

• Installation History tab — This tab displays information on the current and any 
previous configurations of DashBoard installed on your computer. Details such as 
the date of installation and applications installed are also provided. From this 
dialog, you can also Revert to any previously installed software using the Revert 
button.

• Plug-ins tab — This tab displays the ID, name, provider, and version of the 
currently installed plug-ins, or add-on programs, for DashBoard. 

• Configuration tab — This tab displays information such as platform details, 
system properties, and user preferences that can be used for troubleshooting.

Viewing Installation Details
Use the following procedure to viewing the installation details for DashBoard:

1. From the main toolbar, select Help > About DashBoard > Installation Details. The 
DashBoard Installation Details dialog box opens.

2. To view details on the currently installed software features and options for your 
DashBoard application:

• Select the Installed Software tab.
• From the provided list, select the required software feature.
• Click Properties.

3. To view details on your DashBoard installation history:

• Select the Installation History tab.
• Select the required configuration from the Previous configurations: list.
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• The Configuration contents pane updates to include a list of the features and 
options.

4. To view details on the installed plug-ins for your DashBoard application:

• Select the Plug-ins tab.
• Select the required plug-in from the provided list.
• Click Legal Info to display the plug-in licensing agreement.
• Click Show Signing Info to display a new pane that includes the signing date and 

the signing certificate for the selected plug-in. Click Hide Signing Info to close 
the pane.

• Click Columns to configure how information is displayed in the Plug-ins tab.

This completes the procedure for viewing the installation details for DashBoard.

Viewing Error Logs
If you are troubleshooting problems in DashBoard, Ross Technical Support may request that you 
view the error logs for your local DashBoard application.

Use the following procedure to view the error log for your DashBoard application:

1. From the main toolbar, select Help > About DashBoard > Installation Details. The 
DashBoard Installation Details dialog box opens.

2. Select the Configuration tab.

3. Click View Error Log to display the Open With dialog box.

4. Select an application to view the error log information in.

5. Click OK. The error log displays in the selected application.

This completes the procedure for viewing the error log for your DashBoard application.
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Managing openGear Frames in 
DashBoard

In This Chapter
This chapter provides instructions for managing openGear frames in the DashBoard Control 
System. DashBoard connects to an openGear frame using a TCP/IP LAN connection. 

The following topic is discussed:

• Managing openGear Frames in DashBoard

Note — For details on configuring your openGear frame and Network Controller 
Card, refer to the DFR-8300 Series User Manual and the MFC-8300 Series User 
Manual.
DashBoard User Manual (Iss. 4.1) Managing openGear Frames in DashBoard • 3–1



Managing openGear Frames in DashBoard
This section includes information for enabling DashBoard to auto-connect to openGear frames, 
manually adding and re-naming frames to the Tree View, and removing frames from the Tree 
View. When DashBoard is launched, frames are automatically detected and listed in the Tree 
Views. Refer to the section “DashBoard Basic Tree View” on page 4-4 for information on using 
the Basic Tree View. For information on using the Advanced Tree View, refer to the section 
“Using Custom Folders in the DB View” on page 4-6. It is assumed that if you have the 
DashBoard Server and URM feature installed, that your user account is configured for write 
access to the frames communicating with your DashBoard client.

Adding openGear Frames to DashBoard
The DashBoard Control System auto-detects any openGear frame on the same IP subnet, and 
queries the network for new frames every 10 seconds if the Automatic Detection feature is 
enabled in the Preferences menu. Refer to the section “Automatic Discovery” on page 6-3 for 
details.

Each openGear frame lists all devices within the frame, and provides status information in the 
Tree View. You can also remove and disconnect an openGear frame from DashBoard.

Adding openGear Frames to DashBoard
You will need to manually add openGear frames to the Tree View when the frame is on a different 
subnet from DashBoard.

Use the following procedure to manually add an openGear frame to a DashBoard Tree View:

1. Click  on the Tree View toolbar to open the Select Equipment or Service Type to 
Add dialog box. 

2. Select TCP/IP openGear Frame.

3. Click Next > to open the New TCP openGear Frame Connection dialog box. The 
Invalid host name or IP address message remains until you enter text in the IP 
Address field.

New TCP openGear Frame Connection Dialog Box

Operating Tip — You can also select File > New > TCP/IP openGear Frame 
from the main DashBoard toolbar. 
3–2 • Managing openGear Frames in DashBoard DashBoard User Manual (Iss. 4.1)



4. In the text fields provided, enter the IP Address, display name for the frame, and port of 
the openGear frame you wish to add.

5. Click Finish to display the openGear frame in the Tree View. Frames added to the Tree 
View are also displayed in the Advanced Tree View.

This completes the procedure for manually adding an openGear frame to the Tree View. Repeat 
the procedure for each openGear frame that you wish to add to the Tree View.

Re-naming an openGear Frame in the Tree View
There are two methods for re-naming an openGear Frame in DashBoard. The first method is for 
frames manually added to the Tree View as described in the section “Adding openGear Frames 
to DashBoard” on page 3-2. The second method describes how to re-name an auto-detected 
frame using the DashBoard menu options available on the MFC-8300 series cards. Both methods 
are described below.

Re-naming a Manually Added openGear Frame
Use the following procedure to re-name a manually added openGear frame in the Tree View:

1. Right-click the frame you wish to rename.

2. Select Rename Frame.

3. Enter the new name for the frame in the text field provided. 

4. Click OK. 

This completes the procedure for re-naming a manually added openGear frame in the Tree View.

Re-naming an Auto-Detected openGear Frame
Use the following procedure to re-name an auto-detected frame in the Tree View:

1. Right-click the frame you wish to rename.

2. Select Open. A tab displays in the Device View. Note that the tab title includes the slot 
number and the Network Controller Card currently installed in the frame.

3. Select the Network tab.

4. Enter a new name for the frame in the Frame Name field.

5. Press Enter.

6. Click Apply.

This completes the procedure for re-naming an auto-detected openGear frame in the Tree View.

Operating Tip — You can also click Detect Frame Information to enable 
DashBoard to detect the port, name, unique identifier and other connection 
information from the specified IP Address. Once DashBoard detects the information, 
the Automatically Track Updates to Frame Information check box is selected so 
that any changes are automatically updated in DashBoard.

Note — This option is not available if you enabled the Automatically Track 
Updates to Frame Information option. When this option is enabled, follow the steps 
outlined in the section “Re-naming an Auto-Detected openGear Frame”.
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Removing openGear Frames from a Tree View
This section outlines how to remove an openGear frame from a Tree View in DashBoard. Once a 
frame is removed, DashBoard no longer reports the status in the Tree View and you are no longer 
able to monitor or control the affected devices. If communication with a frame is disconnected via 
the Disconnect option, the status indicator is set in light grayed until the frame is re-connected. If 
the status indicator is a dark gray, with the rest of the node appearing normal, a connection cannot 
currently be established to the device.

Use the following procedure to remove or disconnect an openGear frame from the Tree View:

1. If the frame you are removing is in a Custom Folder, you must first delete the frame 
from the Custom Folder before it can be removed from the Tree View.

2. To remove a manually added openGear frame from the Tree View:

• Right-click the openGear frame you wish to remove.

• Select  to remove the openGear frame from the Tree View.

3. To disconnect communications to an openGear frame from DashBoard:

• Toggle  to off.

• Right-click the openGear frame you wish to disconnect.

• Select .

• The frame status indicator is grayed out in the Tree View.

4. To re-connect to an openGear frame:

• Right-click the frame status indicator. 

• Select  or toggle  to on.

This completes the procedure to remove or disconnect an openGear frame from the Tree View.

Auto-Discovery

Selecting  for an auto-detected frame will temporarily remove the frame but the frame will 
re-appear in the Tree View again due to the auto-discovery feature of DashBoard. You must first 
disable the auto-discovery feature before you can remove a frame in this instance. Refer to the 
section “Automatic Discovery” on page 6-3 for details on configuring the auto-discovery 
feature.

However, you can still disconnect from an auto-discovered frame by toggling the Automatic 
Discovery option off.
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Using the DashBoard Interface

In This Chapter
This chapter introduces you to the DashBoard client interface, and how to use in each area. 

The following topics are discussed:

• DashBoard Interface Overview
• DashBoard Basic Tree View
• Using Custom Folders in the DB View
• The Device View Area
• Using Layouts
• Using DashBoard Help
• Preferences

Note — Contact your I.T. Department if you experience communication issues with 
DashBoard and are running anti-virus software. You may need to verify that there is 
an exception in your firewall to allow DashBoard to receive UPD data via Port 427.
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DashBoard Interface Overview
This section includes a brief summary of the DashBoard Control System client interface and its 
components. 

 
Figure 4.1  DashBoard Interface Overview

1. Main DashBoard Toolbar

This area provides access to basic tasks in DashBoard, such as saving layouts, setting preferences, 
and updating Dashboard software.

2. Device View

This area includes Tabs for each device when you double-click a device from the DB View. The 
Device View includes product and configuration details for each card including the card and 
connection status. From this view you can verify the card and connection status, update card 
parameters, and view read-only information. Buttons are provided for refreshing the Device 
View, uploading software or firmware, and re-booting the device. Refer to the section “The 
Device View Area” on page 4-9 for more information.

3. Basic Tree View

This area lists the openGear frames and the cards installed in each frame. From this Tab you can 
open Device Editors, enable auto connections to frames, re-query the network for new devices, 
add new connections, and delete devices from the view. Refer to the section “DashBoard Basic 
Tree View” on page 4-4 for more information. 

4. DB View (Custom Folders)

The DB View (Custom Folders) licensed feature enables you to create a customized layout of 
folders and subfolders in a single Tab. You can re-organize your devices to suit your workflow by 
dragging and dropping devices from the Basic Tree View to any Custom Folder Tab. For more 
information on using the DB View, refer to the section “Using Custom Folders in the DB View” 
on page 4-6.

Operating Tip — You can set the DashBoard interface to full-screen by pressing 
Shift + F11 or selecting Window > Full Screen from the main DashBoard toolbar. To 
exit out of full-screen mode, press Shift+F11 again.
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5. Saved Layouts View

This area enables you to save and restore a series of Device View Tabs and the DashBoard 
window size and position as a Layout. Layouts can be recalled using the options in the main 
DashBoard toolbar or from the Saved Layouts Tab. For more information on recalling layouts, 
refer to the section “Using Layouts” on page 4-11.

If you have the DB View feature installed, saving a layout also saves any open custom folders and 
the set of open Tree Views is saved but the contents of each view is independent of the layout.

Status Indicators
The color of the status indicator beside each openGear frame name, device, custom folders and 
subfolders indicates the status as follows:

• Green — This color indicates that the device is running correctly and communicating 
with the frame. 

• Orange — This color indicates that the Network Controller Card for that frame can only 
support a limited number of connections and that maximum has been reached. You can 
select the Force Connect option, after right-clicking on the frame status indicator, to 
establish a connection between the frame and your DashBoard workstation. However, 
doing so will disconnect another connection to the same Network Controller card.

• Yellow — This color indicates a minor problem with the device.
• Red — This color indicates that the device is offline or has a significant error condition. 

For example, there is no input or reference signal from the card.
• Gray — This color indicates an offline frame in the DB View. If the DB View feature is 

enabled, a gray status beside a device in a custom folder indicates that a different device 
is now installed in the slot. The offline status is also reflected in the Device Tab of any 
open devices for that frame. 

Note — The Frame Status Indicator, the Custom Folders, and the subfolders 
reflect the most negative status of any detected devices. For example, in Figure 4.1 
the Keyers folder in the Custom Folders displays a red status indicator because at 
least one of the cards is reporting an error.
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DashBoard Basic Tree View
This section outlines the Basic Tree View of the DashBoard Control System client. If you have 
installed the DB View feature, refer to the section “Using Custom Folders in the DB View” on 
page 4-6 for details on using this interface.

Overview
The Basic Tree View displays openGear frames in a tree structure. When you launch DashBoard, 
all openGear frames within the same subnet are auto-detected. Refer to the section “Managing 
openGear Frames in DashBoard” on page 3-2 for information on adding frames to the Basic 
Tree View. For information on connecting your openGear frame using a TCP/IP connection, refer 
to your frame user manual or your facility IT personnel. 

The Basic Tree View also displays the cards and status information of each card, installed in each 
detected openGear frame. This allows you to monitor the status and control the card parameters 
from a single computer. Figure 4.2 provides an example of a Basic Tree View. 

 
Figure 4.2  Example of a Basic Tree View

1. Basic Tree View Toolbar

This area provides access to the following basic tasks:

•  Device Editor Button — Selecting this button enables you to edit parameters for 
a selected openGear device. To edit a device, click the device you wish to edit, and select 
this button to display the tab in the Device View for that device. Double-click a frame 
name to display the Device Tab for the MFC-8300 card installed in the frame. You can 
also double-click the device from the Basic Tree View list. 

•  Auto-Connect Devices Button — Toggling this button enables DashBoard to 
automatically connect to devices and display information in the Basic Tree View. The 
default setting is enabled (auto-connect).

•  Re-query the Network Button — Selecting this button enables DashBoard to 
query the network and automatically add any new devices or frames to the DB View. 
Note that DashBoard automatically queries the network approximately every 10 seconds. 
If Automatic Discovery is disabled, you can force a network query by selecting this 
button.

•  Add New Connection Button — Selecting this button opens the New dialog box 
and enables you to manually add an openGear frame to the Basic Tree View. Use this 
button to add a frame that cannot auto-connect but can be found via the network. 
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•  Delete Button — Selecting this button enables you to delete a selected offline or 
manually added frame, or device, from the Basic Tree View.

•  Group Similar Devices Button — This feature is not yet implemented.

2. Frame Status Indicator

A status indicator is displayed for each openGear frame detected by DashBoard and is located to 
the left of the frame name. The status indicator represents the current status of the detected 
devices in the openGear frame. For example, Frame 1 in Figure 4.2 indicates a red status because 
three cards are reporting a red status. A , or an arrowhead, next to a frame status indicator 
signifies that the list can be expanded to display a list of devices installed in that frame. 

3. Device Status Indicator

A status indicator is listed for each openGear device (card) in a frame. This icon includes the card 
status, the slot in which it is installed in that frame, and the card product name. This information 
is detected automatically. To view a card in the Device View, double-click the card status 
indicator. Note that if the device is offline, you cannot open a tab for it in the Device View.

Using the Basic Tree View
Use the following procedure to use the Basic Tree View features:

1. Toggle  on the Basic Tree View toolbar to enable DashBoard to automatically 
connect to the listed openGear frames in the Basic Tree View.

2. To edit an openGear frame:

• Select the openGear frame to edit.

• Click  on the Basic Tree View toolbar. A tab displays in the Device View for 
the selected frame and Network Controller Card.

• Configure the frame parameters as outlined in the MFC-8300 Series User Manual.

3. To add a new connection to the Basic Tree View:

• Click  on the Basic Tree View toolbar to display the Select Equipment or 
Service Type to Add dialog box.

• Add a connection by following the on-screen instructions and the procedure 
“Adding openGear Frames to DashBoard” on page 3-2.

4. To delete an offline openGear frame from the Basic Tree View:

• Select the openGear frame to delete from the Basic Tree View.

• Click  on the Basic Tree View toolbar. The Confirm tree item removal dialog 
box displays.

• Click OK.

5. To open or close a Basic Tree View Tab:

• To open a Tab, select Window > Show View > Basic Tree View.
• To close a Tab, right-click the Basic Tree View Tab, then select Close.

This completes the procedure for using the Basic Tree View features. 
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Using Custom Folders in the DB View
The DB View licensed feature enables you to create a customized layout of folders, each 
displaying the status of select devices. Custom Folders contain a selection of openGear frames 
and installed devices. This feature allows you to drag and drop devices into subfolders, enabling 
you to quickly customize folders as required. All device information is automatically updated 
whenever parameters or status changes occur.

Overview
This section summarizes the DB View Tabs, Custom Folders and subfolders, and the available 
menu options.

Figure 4.3  DB View

1. Custom Folder Toolbar

Like the Basic Tree View, the Custom Folder toolbar includes the Editor, Delete and Add New 
Connection buttons. In addition, there are buttons for creating new subfolders, saving the current 
tree view, saving and restoring device configuration, and accessing the extra menu options of the 
Custom Folders Tab. 

2. Filter Search Field

Each Custom Folder includes a Filter feature that enables you to search the Tree Views by 
entering text into the field. DashBoard automatically displays the search results in the selected tab 
under the All Connections node. For example, to search for a UDC-8225, enter UDC or 8225 in 
the Filter field and DashBoard lists the frames that have a UDC-8225 installed. Expand the 
frames inside the All Connections node to display the specific slots with UDC-8225 cards. To 
clear the Filter field, delete the text.

3. Custom Folders Main Directory

Each DB View Tab includes a Custom Folders directory. In this directory, you can create and 
re-name subfolders to organize devices for customized views. The status indicator represents the 
current status of the devices in the custom subfolder. If a device in the subfolder needs attention, 
the status indicator shows the most critical warning level. For example, the Custom Folders icon 
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in Figure 4.3 indicates a red status because the MDK-111A-Lite in Frame 7 is reporting an error 
condition (a red status). 

Right-clicking a custom folder displays a dialog that includes options for creating a new 
subfolder, connecting or disconnecting devices, and re-naming the folder. To add devices to a 
Custom Folder, simply drag a device or frame from the All Connections directory to the desired 
Custom Folder.

4. Custom Subfolders

A Custom Subfolder displays any number of devices from any openGear frame connected to 
DashBoard. Creating Custom Subfolders allows you to group similar devices together that may 
be installed in different frames, such as the Keyers and UDCs folders in Figure 4.3. If a device in 
the subfolder needs attention, the status indicator shows the most critical warning level. For 
example, the Keyers subfolder in Figure 4.3 indicates a red status because the MDK-111A-Lite 
in Frame 7 is reporting an error condition (a red status). 

Right-clicking a subfolder displays a dialog that includes options for creating a new 
sub-subfolder, connecting or disconnecting devices, re-naming the folder, removing the selected 
subfolder, saving and recalling configuration folders. 

5. Device Status Indicator

A status indicator is listed for each openGear card in a subfolder. This icon includes the card 
status, the slot and frame in which it is installed, and the card product name. This information is 
detected automatically, but you can also re-name the device as required. To view a card in the 
Device View, double-click the card name. Right-clicking a device displays a dialog that includes 
options for opening the device, restoring or saving the configuration, re-naming the device or 
removing the device.

6. Custom Folders Extra Options

Select the  button on the Custom Folder toolbar to display the available Extra Options. 

•  New DB View Tab — This option opens a new DB View Tab in DashBoard.

•  Clear This DB View Tab — This option closes the current DB View and opens a 
new DB View in its place. If you have made any changes to the current DB View, you 
will be prompted to save your work.

• Open DB View — This option enables you to select a previously saved DB View to 
open in the current session of DashBoard.

•  Save DB View — This option saves the selected DB View. If you have re-named 
the main Custom Folder directory, the new name is now displayed. An asterisk displays 
next to the Custom Folder Tab name when there are unsaved changes for that Tab.

•  Save DB View As… — This option saves the selected DB View under a new 
filename. 

•  Import DB View — This option enables you to import a DB View from another 
location or DashBoard computer.

•  Export DB View — This option enables you to export a DB View to another 
location or DashBoard computer.

•  New Folder — This option enables you to create a new subfolder in the DB View.

•  Save Configuration to File — This option is only available when using the 
MFC-8310-N and MFC-8320-N Network Controller Cards. For more information on this 
feature, refer to the section “DataSafe Overview” on page 5-2.
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•  Restore Configuration — This option is only available when using the 
MFC-8310-N and MFC-8320-N Network Controller Cards. For more information on this 
feature, refer to the section “DataSafe Overview” on page 5-2.

•  Show Device List — Selecting this option displays or hides the list of connected 
frames and devices in the DB View Tab.

•  Delete DB View — This option deletes the current custom folder directory from 
DashBoard.

Using the DB View
Use the following procedure to use the DB View features:

1. Ensure the DB View software license is installed. Refer to the section “Activating 
DashBoard Licensed Features” on page 2-6 for installation details.

2. To open a new DB View Tab in DashBoard, select DB View > New DB View Tab.

3. To add a new subfolder to the Custom Folders directory of a DB View Tab, use one of 
the following methods:

• Right-click the Custom Folder icon, and then select . You are prompted to enter 
a name for the new subfolder; or,

• On the Custom Folder toolbar, click , then select . You are prompted to enter 
a name for the new subfolder.

4. To add devices to a subfolder:

• Select the device from the All Connections directory or any available Tree View.
• Drag and drop the device status indicator to the desired subfolder. The Add to 

Custom Folder? dialog box displays. 

• Re-name the device, if desired, by entering a new name in the Name Prefix field. 
Note that the new name only applies to the device in the Custom Folder view.

• Click OK.

5. To re-name a subfolder:

• Right-click the subfolder icon.
• Select Rename to display the Rename dialog box.
• Enter the new name in the Name: field.
• Click OK.

6. To clear the DB View Tab:

• On the Custom Folder toolbar, click .

• Select .

7. To open or close a DB View Tab:

• To open a Tab, select Window > Show View > DB View.
• To close a Tab, right-click the Custom Folders Tab, then select Close.

This completes the procedure for using the DB View features. 

Operating Tip — You can re-organize devices in a subfolder using the drag and 
drop method.
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The Device View Area
This section includes a summary of the Device View Area and includes general instructions for 
managing devices in the DashBoard client.

Overview
The Device View Area includes tabs of devices selected from the Basic Tree View. Devices are 
added, as Tabs, to the Device View Area by double-clicking the slot number in the Basic Tree 
View. Selecting a Device Tab enables you to view the information on that device. You can 
organize Tabs in the Device View by dragging and dropping the Tabs.

Each Device Tab is labeled with the status indicator, the name of the openGear frame, the slot 
number that the device is installed in, and the device type. Figure 4.4 provides an example.

 
Figure 4.4  Device Tab in Device View Area

1. Device Tab Title

This area displays the card status, openGear frame, the slot that the card is installed in, and the 
product name. This information is reported automatically. 

2. Hardware Status

This area displays the card status as reported by the device, and details about the connection 
status. 

3. Read-Only Information 

This area includes read-only information such as the status parameters as reported by the device. 
The parameters and options in this area are dependant on the device selected, but can include the 
product details such as software versions, hardware information, and signal status. In Figure 4.4, 
the Tabs are named Product, Hardware, and Signal, and display as read-only fields. 

4. Settings and Parameters Area

The contents of this area are dependant on the device selected. Available parameters depend on 
the device, but can include source selection, video format and timing settings, alarm reporting 
options, and audio parameters. All changes to device parameters are immediate. Refer to your 
device manual for specific settings and parameters details.
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5. Button Area

The following buttons are available in each Device Tab:

• Refresh — Use this button to request the latest information from the device.
• Upload — Use this button to upload new software to the device.
• Reboot — Use this button to instruct the device to reboot. 
• Close — Use this button to close the Device Tab.

Using the Device View
Use the following procedure to use the Device View Area:

1. To display a Device Tab, double-click a device in the Basic Tree View. 

2. Configure settings and control parameters using the remaining Tabs in the Device View. 
The available Tabs depends on the device. Refer to the user manual for your device for 
information on the available menus and parameters.

3. To refresh the parameters of a device, click Refresh on the Device Tab.

4. To update the software for the device, click Upload and follow the instructions in the 
section “Upgrading Device Software” on page 6-5.

5. To maximize or minimize a tab in the Device View, double-click the desired Device Tab.

6. To organize the Tabs in the Device View: 

• Dock or undock the DB View and Layout List from the DashBoard window by 
dragging it outside the DashBoard window.

• Drag and drop the Device Tabs to organize a layout as required. For information on 
saving and recalling layouts, refer to the section “Using Layouts” on page 4-11.

7. Close a Device Tab as follows:

• Right-click the Device Tab you wish to close.
• Select one of the following options:

› Close — Closes the selected Device Tab. 
› Close Others — Closes all other Device Tabs in the Tab Group but the 

highlighted Tab.
› Close All — Closes all Device Tabs in that Tab Group.

This completes the procedure to use the Device View Area. 

Operating Tip — You can also right-click the device and select Open, or drag 
and drop the device from the DB View to the Device View.
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Using Layouts
This section summarizes the Layout feature of the DashBoard client interface. Information on 
creating, saving, and managing layouts in the Device View is also included.

Overview
Layouts are used to save window configurations in your DashBoard interface. For example, you 
can save a layout which shows a certain set of devices open in the Device View Area. You can 
also determine how these Device Tabs are displayed (Tabbed or tiled, or in Tab Groups), and 
whether any Custom Folder Tabs are included.

Layouts can also save how each component of DashBoard is displayed. For example, you can 
save a layout which maximizes the DashBoard window without displaying the Basic Tree View 
tab.

Each layout saves the DashBoard window state, size, and position. Note that the size and position 
of any undocked tabs are not saved. When restoring layouts from the Layout List, you can toggle 
whether to use the stored layout, or the current layout, of the open window with the three 
right-hand buttons on the toolbar.

Layout List

The following buttons are available in the toolbar of the Layout List, from left to right:

•  Save Layout — Use this button to open the Save Current Layout dialog box.

•  Delete the Selected Layout — Use this button to delete the currently selected 
layout in the Layout List.

•  Maintain Window State — Click this button to keep the DashBoard window at its 
current state when restoring a layout (maximized or sized). Click the button again to turn 
off this feature.

•  Maintain Window Size — Click this button to keep the DashBoard window at its 
current size when restoring a layout (if not maximized). Click the button again to turn off 
this feature.

•  Maintain Window Position — Click this button to keep the DashBoard window 
at its position on the desktop when restoring a layout. Click the button again to turn off 
this feature.
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Managing Your Layouts
Once your DashBoard window and Device Tabs are organized the way you wish, you can save 
this configuration as a new Layout. 

Use the following procedure to manage your layouts in the Layout List:

1. If the Saved Layouts Tab is not displayed in DashBoard, you can display a tab by 
selecting Window > Show View > Saved Layouts.

2. To organize the Device Tabs in the Device View:

• Click the Tab you wish to move in the Device View.
• Drag and drop the Tab in the Device View to the new location within the DashBoard 

window.

3. To move a DB View Tab in DashBoard:

• Click the Tab you wish to move.
• Drag and drop the Tab to the new location within the DashBoard window. Black 

positioning arrows display to indicate the new location.
• Undock the Tab from the DashBoard window by dragging it outside the DashBoard 

window. Black positioning arrows display to indicate the new location.

4. To restore a layout from the Layout List, double-click the name of the layout in the 
Layout List.

5. To save the current layout:

• Click  in the Layout List to open the Save Current Layout dialog box.

• Enter a name for the new layout in the text field provided.
• Click OK.

6. To rename a layout in the Layout List:

• Right-click the layout in the Layout List.
• Select Rename to open the Rename Layout dialog box.
• Enter a new name for the layout in the text field provided.
• Click OK. The new name for the layout displays in the Layout List.

This completes the procedure to save a new layout to the Layout List.

Deleting a Layout
Use the following procedure to delete a layout from the Layout List:

1. In the Layout List, select the layout you wish to delete.

2. Click .

The Confirm Layout Delete dialog box opens.

3. Click OK.

The layout is deleted from the Layout List.

This completes the procedure to delete a layout from the Layout List.
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Using DashBoard Help
The DashBoard Help system is accessed by selecting Help > Help Contents from the main 
toolbar of DashBoard. The DashBoard Help displays, by default, the Contents pane and Search 
box in the toolbar. 

The following Help Systems are currently available in DashBoard:

• DashBoard Help — This is the main Help system for the DashBoard Control System 
that is available by choosing Help > Help Contents from the main toolbar. DashBoard 
Help provides information on the various features and options available in DashBoard. 
Context-sensitive Help is also available by selecting an interface item, such as the Basic 
Tree View tab, and clicking F1 (when running Microsoft® Windows®). 

• openGear Help — This feature provides information on individual openGear devices, 
such as frames and cards. You can access the openGear Help for your device by selecting 
the device in the Tree Views and clicking F1 (when running Microsoft® Windows®) or 
by choosing openGear from the Help dialog box. An option is provided for importing 
new help files for openGear devices.

This section briefly summarizes how to configure the DashBoard Help display options and 
import new help files.

Configuring the DashBoard Help Display Options
This section summarizes how to configure the DashBoard Help display features:

• Open Window Context Help — This is the context-sensitive help that is displayed when 
you click F1 (when using Microsoft® Windows®) in the main DashBoard window. 

• Dialog Context Help — This is the context-sensitive help in a dialog box.

Use the following procedure to configure the Help display options for DashBoard:

1. From the main toolbar, select Window > Preferences. The Preferences dialog box 
opens.

2. Select Help. The Help dialog box opens. 

3. Specify the browser used to display the DashBoard Help search results by selecting one 
of the following options from the Open help search menu.

• In the dynamic help view — Select this option to display the DashBoard Help 
search results in a new pane of the DashBoard interface. This is the default setting.

• In a browser — Select this option to display the DashBoard Help search results in 
your default web browser.

4. Specify how to display help documents, such as user manuals in *.pdf format, by 
selecting one of the following options from the Open help view documents menu.

• In place — The help document is displayed in the same tab as the link to the 
document. This is the default setting.

• In the editor area — The help document is displayed in a new tab in DashBoard.
• In a browser — The help document is displayed in your default web browser.

5. Specify how to display the DashBoard Help contents by selecting one of the following 
options from the Open help contents menu.

• In the help browser — The DashBoard Help content is displayed in a new pane of 
the DashBoard interface. This is the default setting.
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• In an external browser — The DashBoard Help content is displayed in your 
default web browser.

6. Specify how the openGear Help is displayed by selecting one of the following options 
from the Open window context help menu:

• In the dynamic help view — The selected Dialog Context Help is displayed in a 
new pane of the DashBoard interface. This is the default setting.

• In an infopop — The Help content is displayed as a persistent popup message.

7. Specify how to display the openGear Help by selecting one of the following options 
from the Open dialog context help menu.

• In a dialog tray — The DashBoard Help content is displayed in a new pane of the 
DashBoard interface. This is the default setting.

• In an infopop — The Help content is displayed as a persistent popup message.

8. Click Apply to save your changes. You can also click Restore Defaults to disregard 
any changes you have made.

This completes the procedure for configuring the DashBoard Help display features.

Importing openGear Help
DashBoard allows you to download and install additional help files provided by your openGear 
manufacturer, enabling you to display the most recent help files for your device. There are two 
methods for importing openGear Help: 

• Importing openGear Help Files — This method enables you to import a file or 
directory from a location on your network to your DashBoard workstation. Use this 
method if you are running Apple® Mac® OS® or Linux® Fedora®.

• Installing a Ross Video openGear Help Pack — This method installs an additional 
DashBoard Help feature that provides a library of Ross Video openGear user manuals. If 
you are running Microsoft® Windows®, use the procedure provided in the section 
“Installing DashBoard Add-on Programs” on page 2-5. Otherwise, use the procedure 
for importing openGear Help Files. 

Importing openGear Help Files
This section briefly summarizes how to import openGear Help Files into DashBoard. If your 
openGear manufacturer has provided a Help Pack Add-on program and your computer is running 
Microsoft® Windows®, use the procedure “Installing DashBoard Add-on Programs” on 
page 2-5.

Use the following procedure to import openGear Help Files:

1. Contact your openGear manufacturer to determine if additional help files are available 
for your device(s). 

2. From the main toolbar, select File > New > Other... The Select Equipment or Service 
Type to Add dialog box opens.

3. Select Import openGear Help Files from the list.

4. Click Next >. The Import openGear Help File(s) dialog box opens.

Note — The Include help content from a remote info-center option is not 
implemented.
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5. From the Add Help From list, select the type of file to import:

• File — Select this option if the help file is a PDF, or is in a zip file. Proceed to step 
6.

• Directory — Select this option if the help file has been extracted to a directory. 
Proceed to step 6.

• Download — Select this option if the help file is to be downloaded from the 
manufacturer website. Proceed to step 7.

6. If you selected File or Directory:

• Click Browse... in the Selected Help area.
• Navigate to the file you wish to import.
• Click Open to return to the Import openGear Help File(s) dialog box. Note that 

the file location is now displayed in the Selected Help field.
• Click Finish to import the file into DashBoard.

7. If you selected Download:

• Enter the URL of the help file in the Selected Help field.
• Click Finish to import the file into DashBoard.

This completes the procedure for importing openGear Help Files into DashBoard. To view your 
new help file, choose Help > Help Contents from the main toolbar and select the file from the 
openGear node.
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Preferences
This section briefly outlines additional options available in the Preferences menu in DashBoard.

Secure Storage
Ross Video recommends that the Secure Storage feature be configured only by system 
administrators, or as directed by Ross Technical Support when troubleshooting.

Web Browser
The Web Browser feature enables you to add, remove, or edit installed web browser applications 
for your computer running DashBoard. Ross Video recommends leaving the options for this 
feature at the default states (where the Use internal Web browser is selected and the External 
Web Browser is set to the default web browser application for your computer). 

Note — The Web Browser feature is not yet implemented.
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DataSafe™

In This Chapter
This chapter provides instructions for configuring and using the DataSafe™ feature in 
DashBoard. Refer to the MFC-8300 Series User Manual for details on setting up your Network 
Controller Card.

The following topics are discussed:

• DataSafe Overview
• DataSafe Basics
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DataSafe Overview
This section briefly outlines the DataSafe feature. DataSafe enables you to replace a failed card 
and apply the original card parameters to the working card. This feature is enabled or disabled on 
a slot-by-slot basis and currently defaults to OFF. DataSafe also enables you to save card 
parameters to a file, and later restore those parameters to one or more cards of the same type. 
Multiple configuration sets can be stored if required. This gives you the flexibility of configuring 
a large number of cards identically from a single stored configuration. 

This feature is available for frames using the MFC-8310-N and MFC-8320-N series cards only. 

Figure 5.1  DataSafe Tab Overview 

1. DataSafe Tab in the Device View

The DataSafe Tab is available in the Device View of a MFC-8310-N series or MFC-8320-N 
series Network Controller Card. The tab lists the cards installed in the frame in slot ascending 
order. The following items are displayed in the tab:

• Slot Name — The slot name is set in the Card Slots Names field of the Setup Tab. The 
physical slot that the card is installed in is indicated by the number in brackets after the 
Slot Name. For more information on re-naming slots, refer to the section “Re-naming an 
openGear Slot in the Tree View” on page 6-2.

• Card Type and Software Rev fields — This area indicates the card installed in the slot 
and the software version. The information is displayed in the form of xxxx :: #### :: y 
where xxxx represents the card type, #### represents the software revision, and y 
represents the card status. If the field is blank, there is no saved data for this slot. For 
example, in Slot 3 of Figure 5.1, the UDC-8225 is running with software version 2.11 
while Slot 2 does not have a card installed.

• Correct Mismatch fields — This area includes the Update Slot button. Clicking this 
button automatically updates the slot with the new card information indicated in the 
Conflict field.

• Conflict fields — This field is blank if the card currently in the slot has the same card 
type and software version as the saved DataSafe data. When the software version or the 
card type do not match the saved data for the slot, the Conflict field for that slot is 
populated with the new information, alerting the user that a new configuration is 
available for that slot. The information is displayed in the form of xxxx :: #### :: y where 
xxxx represents the card type, #### represents the software revision, and y represents the 
card status. If the field is blank, there is no saved data for this slot.

1

2

3
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• Disable check box — This option disables the DataSafe feature for that slot.
• Force button — If any slots have a software version mismatch, the Force button allows 

the user to load the current DataSafe data to the cards and overwrites the frame-stored 
data with the card’s current settings. This button is enabled only if a software version 
incompatibility exists. For more information on forcing DashBoard to update cards with 
software incompatibilities, refer to the section “Forcing DataSafe Updates” on 
page 5-7.

• Mask Warning check box — The Network Controller card displays a warning in the 
Data Safe State field of the Hardware tab if any of the card slots have an error. For 
example, if a card is installed that does not match the last saved data for that slot. If the 
check box is selected, no warnings are displayed in DashBoard. The default setting is to 
display warnings and errors.

2. Save/Restore Card Parameters in the Basic Tree View

The following DataSafe options are available when you right-click a device in the Basic Tree 
View:

•  Save Configuration to File — Selecting this option displays the Export Slot to 
file dialog from which you can save a DataSafe file for the specific card on your 
DashBoard host machine. For more information on saving DataSafe files, refer to the 
section “Saving a DataSafe File” on page 5-4.

•  Restore Configuration — Selecting this option displays the Restore 
Configuration Wizard from which you can restore from a DataSafe file for the specific 
card(s) on your DashBoard host machine. For more information on recalling 
configurations from a file, refer to the section “Restoring Configurations to Devices” 
on page 5-5.

3. Save/Restore Configurations for Devices in the DB View

If the DB View licensed feature is installed, the following options are available in the Custom 
Folder toolbar:

•  Save Configuration to File — Selecting this option displays the Export to file 
dialog from which you can save the configuration of all the devices in the Custom Folder 
View to a single DataSafe file.

•  Restore Configuration — Selecting this option displays the Configuration 
Wizard from which you can recall all configurations for all devices in the Custom Folder 
View from a *.tvc file. 
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DataSafe Basics
This section provides instructions for basic DataSafe operation such as re-naming a slot, saving 
and recalling DataSafe files. DashBoard saves all card parameter values to the file which is stored 
locally on the DashBoard host machine. 

Saving a DataSafe File
DashBoard enables you to save card parameters to a unique DataSafe file which you can name 
and store on your computer. If you are using the DB View, an option also exists that enables you 
to save the configuration of all devices in the specified custom folder. Both methods are described 
in this section.

Saving a DataSafe File for a Specific Device
This section outlines how to save a DataSafe file containing all of the data of a specific card 
including the card parameters and settings, frame name, slot name and number, card type, and 
software revision. This option is always available regardless of which Network Controller card is 
used and which software options have been purchased.

Use the following procedure to save a DataSafe file for a specific device:

1. From the Tree View, right-click the card you wish to save the configuration for.

2. Select  to display the Export to file dialog box.

3. Navigate to the location you wish to save the file to.

4. Enter a filename in the File name: field. 

5. Ensure the Save as type: field is set to openGear Device File (*.ogd). 

6. Click Save.

This completes the procedure for saving a DataSafe file for a specific device.

Saving a DataSafe File for a Group of Devices
This section outlines how to save the configuration of devices in the Custom Folder View to a 
single DataSafe file. This file is in the format *.tvc (Tree View Configuration) and is stored on the 
DashBoard host machine. 

Use the following procedure to save a DataSafe file for a group of devices:

1. From the DB View, select the Custom Folder to save the configuration for.

2. Select  to display the Export to file dialog box.

3. Navigate to the location you wish to save the file to.

4. Enter a filename in the File name: field. 

5. Ensure the Save as type: field is set to Tree View Configuration (*.tvc). 

6. Click Save.

This completes the procedure for saving a DataSafe file for a specific device.

Note — Some openGear cards have card-edge jumper settings that disable remote 
control. Ensure that your card is configured to enable control from DashBoard before 
saving and recalling DataSafe files.
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Restoring Configurations to Devices
DashBoard can send a DataSafe file to a specific Network Controller Card and slot for use. Once 
received, the Network Controller Card updates the card if the installed card matches the data sent. 
You can also choose to copy parameters from a card to a single device or group of devices. Both 
methods are described in this section. 

As part of the recall process, DashBoard opens a DataSafe file, examines the card type and 
software revision, and determines what devices on the network in the current Tree View that 
match. The user can then select which card(s) to update with the new values. 

Restoring a DataSafe File
This section outlines how to recall a saved DataSafe file on your DashBoard host machine to a 
single type of device your network.

Use the following procedure to recall a DataSafe file:

1. From the Tree View, right-click the device to update.

2. Select  to display the Restore Configuration Wizard dialog box.

3. From the Configuration Source list, select Load Parameters from a File.

4. Click Next > to display the Select Device File menu.

5. In the Configuration File field, enter the DataSafe file to download to your card or click 
Browse... to navigate to the file location on your DashBoard host machine.

• Ensure that the select file is a valid *.ogd file.
• Information, such as the card type, slot and frame names, is displayed in the Device 

Info: field. An error message will also display in this field if a card type or software 
version mismatch will occur.

6. Click Next > to display the Select Destination menu. The Select Destination menu 
provides a list of the compatible cards based on the card selected in step 1.

7. Select the device(s) to recall the file to: 

• From the Select Destination list, select the check box(es) for the devices you wish 
to recall the file to. 

• Verify that the device(s) you wish to recall the file to. The Error/Warning fields 
indicate any errors, such as incompatible software or card type mismatch.

8. Click Finish.

This completes the procedure for recalling a DataSafe file.

Restoring Parameters for a Group of Devices
You can recall all configurations for all devices in an DB View from a *.tvc file. Card parameters 
will only load from the DataSafe file if the card type matches and the software versions are 
compatible.

Use the following procedure to recall parameters for a group of devices in the DB View:

1. From the DB View, select the Custom Folder to recall the configuration file for.
2. Select  from the Custom Folders toolbar to display the Restore Configuration 

Wizard.

Note — You must have an MFC-8310-N series or MFC-8320-N series installed in 
the frame to recall DataSafe data or files.
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3. From the Configuration Source field, select Load Parameters from a File to display 
the Select Device File menu.

4. To enter a filename in the Configuration File: field:

• Click Browse... to navigate to the file location on your DashBoard host machine.
• Ensure that the select file is a valid *.tvc file.
• Information, such as the card type, slot and frame names, is displayed in the Device 

Info: field. An error message will also display in this field if a card type or software 
version mismatch will occur. 

5. Click Next > to display the Select Destination menu. The Select Destination menu 
provides a list of the compatible cards based on the card selected in step 1.

6. Select the devices to restore as follows:

• From the Select Destination list, select the check box(es) for the devices you wish 
to recall the file to. 

• The Error/Warning fields indicate any errors such as incompatible software or a 
card type mismatch.

7. Click Finish.

This completes the procedure for restoring parameters for a group of devices.

Copying Parameters
Use the following procedure to copy parameters from one device to another:

1. From the Tree View, right-click the device to update.

2. Select  to display the Restore Configuration Wizard dialog box.

3. From the Configuration Source, select Copy Parameters from another Card.

4. Click Next > to display the Select Source Device menu.

5. From the provided list, select the card whose settings will be copied.

6. Click Next > to display the Select Destination menu.

7. From the provided list, select the device(s) to copy the parameters to. The 
Error/Warning fields indicate errors such as software or card type mismatch.

8. Click Finish.

This completes the procedure for copying parameters from one device to another.

Notes on Saving and Restoring Parameters
This section provides brief operational notes when saving and restoring parameters:

• The Restore Configuration Wizard dialog box includes the Hide invalid destinations 
check box. Selecting this check box hides cards in the Select Destination list that are not 
applicable based on the card type you selected to restore and the software of that card. 
Only those cards that are the same type and compatible software versions will be listed.

• The Select Destination list displays the frame and cards in the same format as seen in the 
Tree View. For example, if the frame node is expanded in the Tree View, the same node is 
expanded in the Select Destination list.

• You can select all devices in a single frame by selecting the checkbox beside the frame 
entry in the Select Destination list.
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• The  indicator beside the frame name in the Select Destination list indicates that at 
least one device in that frame is selected. A checkbox beside the frame name indicates 
that all the devices in that frame are selected.

Forcing DataSafe Updates
If any slots have a software version mismatch, the Force button allows the user to have the 
current DataSafe data loaded to any slots where a software mismatch is occurring. This button 
and text only displays if a software version mismatch occurs in the DataSafe tab. 

The following tasks are performed when the Force button is clicked:

• Loads all of the data from the card
• Stores the data as the new DataSafe data
• Clears the information in the Conflict field
• Updates the Slot field in the DataSafe tab

Note — A mismatch is reported in the Conflict field of a slot if a new card is 
installed into that slot is a different card type, or has a software incompatible version, 
than the current DataSafe file. If this new card remains installed into that slot for 
more than approximately 24 hours, then the parameters of the new card will 
automatically be saved as the new DataSafe file.
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Configuring Devices

In This Chapter
This chapter provides information on configuring devices in DashBoard. 

The following topics are discussed:

• Configuring Devices in DashBoard
• Upgrading Device Software
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Configuring Devices in DashBoard
DashBoard enables you to configure devices in real-time. Each device has specific configuration 
parameters, depending on the device you have selected in the Tree View. For example, you may 
wish to change a specific parameter on a device while it is online in your openGear frame, 
re-configure a device, or upload new software when it becomes available to a device. 

Configuring Devices in DashBoard
Use the following procedure to configure and verify device information in DashBoard:

1. From the Tree View, double-click a device to display a corresponding Device Tab in the 
Device View. In the following example, the Device View displays settings for the 
UDC-8225A-W located in Slot 12 of Frame 2.

 
Device Tab Example

2. Configure the required parameters using the controls provided in the Settings Area, 
such as those in the Setup Tab seen in the previous example. Refer to the manual for 
your device for information on available parameters and menus.

This completes the procedure for configuring and verifying device information in DashBoard.

Re-naming an openGear Slot in the Tree View
DashBoard offers two methods to re-name a card slot. Both methods are described in this section.

• Using the Setup tab of the Network Controller Card — Use this method to rename the 
card and have the change effective for the network. The new name displays in all 
DashBoard Tree Views for all DashBoard workstations connected to that card.

• Using the Rename option for a Custom Subfolder item — Use this method to rename 
the card for your local DashBoard workstation only. Other DashBoard workstations will 
not display the new name.

Caution — Using the Reboot button takes the card off-air during the reboot cycle.
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Using the Setup Tab
Use the following procedure to re-name a card using the Setup Tab:

1. From the Tree View, double-click the Network Controller Card to display a 
corresponding Device Tab in the Device View.

2. Select the Setup tab.

3. In the Card Slot Names section of the Setup tab, locate the slot you wish to re-name.

4. Enter the new name for the card slot in the text field provided.

This completes the procedure for re-naming a card using the Setup Tab. The new name displays 
in all instances of the card for all DashBoard workstations.

Using the Rename Option
Use the following procedure to re-name a card using the Rename option:

1. From the Custom Folder in the DB View, right-click the card you wish to re-name.

2. Select  to display the Rename dialog box.

3. Enter the new name for the card slot in the Name: field.

4. Click OK.

This completes the procedure to re-name a card using the Rename option. The new name is only 
displayed on your local DashBoard workstation.

Automatic Discovery
The Automatic Discovery feature is enabled by default, and allows DashBoard to automatically 
search for new devices. You can specify that DashBoard search all interfaces on the same 
network, or search only those interfaces you have selected. 

Use the following procedure to configure the Automatic Discovery feature:

1. From the main toolbar, select Window > Preferences. The Preferences dialog box 
opens.

2. Select Automatic Discovery. The Automatic Discovery dialog box opens.

Automatic Discovery Dialog Box

3. Select the Enable check box in the Automatic Discovery of devices section to enable 
the feature. Deselecting the check box disables the Automatic Discovery feature.

4. Select a Discovery mode as follows:
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• All network interfaces — Select this option to enable DashBoard to find 
openGear cards only on the local network. DashBoard queries the network every 10 
seconds and display new devices in the Tree Views. This is the default setting.

• Selected network interface(s) — Select this option to enable DashBoard to 
query the specified network every 10 seconds and display new devices in the Tree 
Views.

5. Click Apply.

 This completes the procedure for configuring the Automatic Discovery feature.

Troubleshooting
If you are unable to make changes to the parameters of a device, or the Upload or Reboot 
buttons are disabled:

• verify that any edit permissions for the device are enabled in the Device Tab.
• verify any relevant card-edge controls on your card are set to enable remote control. 

Removing Offline Devices
An offline device is still listed in the Tree View, with a grayed out status indicator, however 
DashBoard no longer communicates with the device. You can remove all offline devices within 
an openGear frame from the Tree View using the following procedure.

Use the following procedure to remove all offline devices in an openGear frame:

1. In the Tree View, right-click the frame which has the offline device.

2. Select Remove offline devices to remove the offline device from the Tree View. 

This completes the procedure to remove all offline devices in an openGear frame. 

Note — Not all openGear devices support the edit permissions feature and it is recommended 
that you refer to the documentation for your device for details. This control typically appears on 
the Setup Tab of the Device View.

Operating Tip — You can also select the device and right-click to remove it from the Tree 
View.
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Upgrading Device Software
DashBoard enables you to upload software updates to multiple devices available in the Tree 
View regardless of the frame they are installed in. You can select any number of similar cards to 
upgrade (upload software files to) and monitor the upgrade progress. 

Upgrading Device Software
This section outlines the upload software process. The method for uploading software is the same 
regardless of the number of devices you are upgrading. 

Use the following procedure to upload software to a device:

1. Contact your openGear Technical Support representative for the latest software version 
for your device.

2. Display the Device Tab of the device you wish to upload software to.

3. In the Device Tab, click Upload to display the Select File Upload menu of the Upload 
Software Wizard.

4. Select a file to upload as follows:

• Click Browse... to navigate to the *.bin upload file you wish to upload. DashBoard 
automatically selects the last directory that you loaded a file from. 

• Select a file to upload.
• Select Open to return to the Select File Upload menu.
• The Select File Upload dialog box now displays the path to the selected file, and 

information on the selected file such as name, type, load size, and creation date. A 
warning is displayed in the Warnings field when software conflicts occur, such as 
the selected file will downgrade the selected device.

5. Click Next > to display the Select Destination menu.

6. Select the device(s) you wish to upload the selected software file to as follows:

• Note that only the card you selected in is selected.
• If you wish to include other cards, select the desired cards from the Select 

drop-down list using one of the following options:
› Select All — This option selects all the similar devices. The selected software 

file will be uploaded to all devices on the network. 
› Select Without Warnings — This option selects only those devices that do 

not include a conflict with the selected software file.
› Select Without Warnings (include downgrades) — This option uploads the 

software to similar devices that do not have any conflicts, but will include 
those devices that will be downgraded if the selected software file is uploaded 
to them.

› Select None — This option clears all the check boxes in the Device field.
› Click Select.

• The Device field, located below the Select drop-down list, displays information 
such as the device name and slot information, frame it is installed in, the current 
software version, and any applicable error messages are displayed.

• You can also select the devices to upgrade by selecting or clearing the 
corresponding check boxes in the Device field.
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• If the Hide invalid destinations check box is selected, the menu only displays 
similar devices for the selected software file. For example, if you are attempting to 
upload a software file for a UDC-8225, only UDC-8225 cards will be displayed. If 
the check box is cleared, all devices currently installed on the network are displayed 
but are grayed out.

7. Click Finish. The Uploading to Selected Devices menu displays and the upload 
process begins. A progress bar displays in the Uploading to Selected Devices menu for 
each device you selected in step 6.

8. Monitor the upgrade process bar(s) displayed in the Uploading to Selected Devices 
menu while the software is upgraded to your device. You can also display the Uploading 
to Selected Devices menus as a new tab in DashBoard, allowing you to work in other 
DashBoard areas during the upload, by selecting the Run in Background.

9. When the upload is complete, click OK to close the Uploading to Selected Devices 
menu.

This completes the procedure to upload software to a device.

Troubleshooting the Software Upload Process
Use the following information if the software upload process has failed:

• If the “Selected file does not exist” or “Selected file is not a valid upload file” error 
conditions are displayed in the Upload Failed dialog box, select OK from the dialog box 
and re-start the upload process and select the correct file.

• If a “No response from device” condition is encountered, the upload failed while in 
progress due to loss of power or communications. Verify that the card is powered up and 
that you have communication to the openGear frame. You must then restart the upload 
process.

Important — Clicking  during an upload can leave the card in an invalid state. 
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Notes:



Contact Us

Contact our friendly and professional support representatives for the following:

• Name and address of your local dealer
• Product information and pricing
• Technical support
• Upcoming trade show information  

Visit Us
Please visit us at our website for:

• Company information
• Related products and full product lines
• On-line catalog
• News
• Testimonials

Ross Video Part Number: 8351DR-004-4.1

PHONE

General Business Office 
and Technical Support 613 • 652 • 4886

After Hours Emergency 613 • 349 • 0006

Fax 613 • 652 • 4425

E-MAIL 
General Information solutions@rossvideo.com

Technical Support techsupport@rossvideo.com

POSTAL
SERVICE

Ross Video Limited
8 John Street,
Iroquois, Ontario, Canada
K0E 1K0

Ross Video Incorporated
P.O. Box 880,
Ogdensburg, New York, USA
13669-0880
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